Auteur Sujet: Comprend pas la directeion de X-Y  (Lu 93 fois)

cameleon

  • Newbie
  • *
  • Messages: 15
    • Voir le profil
Comprend pas la directeion de X-Y
« le: 09 juillet, 2017, 06:12:02 pm »
Bonjour,

J'ai construit une Smartcore en bois. D'après moi le montage est correct. Les courroies sembles monter au bon endroit.

Mais quand je demande de bouger d'une certaine longueur en X ou en Y (par exemple de 50mm), les deux axes bouge en même temps.

Par exemple si je demande a X de se déplacer de 50mm ," Y" va aussi bouger. Comme je suis encore en test, je n'ai pas encore imprimer avec, de toute façon pour une façon inconnu le moteur de l'extrudeur ne fonctionne pas... Je pense que le nema est défectueux.

J'ai pris le firmeware de Smartcore chez Github (https://github.com/smartfriendz/smartcore).

Je me demande aussi sur quelles pins vont les EndStop, (Ramps 1.4) il y a 2 positions pour X,Y, et Z, comme je ne comprend rien dans les firmewares de Marlin, normalement je branche sur le premier de chacun, mais avec le Marlin de GitHub (MK7 ou MK8), je ne suis pas certain que c'est les même positions ?????

Voir quelques photos: remarquer, l'imprimante à l'heure actuelle est tout brancher, mais pas sur les photos plus bas.









Merci

cameleon
« Modifié: 09 juillet, 2017, 06:20:11 pm par cameleon »

spyd

  • Global Moderator
  • *****
  • Messages: 1943
    • Voir le profil
  • 3d printer: smartrapcore alu
  • buying date: décembre 2015
  • country/Pays: France
  • region/departement: haute-savoie 74
Re : Comprend pas la directeion de X-Y
« Réponse #1 le: 09 juillet, 2017, 06:47:44 pm »
Les end stop doivent etre branché en sur les pin min des axe correspondant.




Pour ton pb d'axe, plusieur piste, à mon avis la plus logique c'est un des moteur à inversé ou bien un des moteur qui ne tourne pas ou il ne tourne pas à la même vitesse (mais ils son normalement la même valeur de pas/mm dans le firmware).


Les 2 moteur doivent fonctionner en parallèle pour bougé sur un seul axe (comme les ardoises magique, on devait tourner les 2 bouton pour tenté une ligne droite XD).


Le mk7 ou mk8 c'est juste pour la taille de la poulie d'entrainement de l'extrudeur rien à voir avec les end stop. Suivant le modèle ce n'est pas le même nombre de pas par mm pour le moteur de l'extrudeur.


Sinon beau travail, c'est une belle bête.
Branchement du ventilo de tête sur le bornier d'alim = HOTEND bien ventillée!!!!!

My thingiverse : http://www.thingiverse.com/spyd6/designs
powerfull tools, free and privacy friendly : https://framasoft.org/[/url

cameleon

  • Newbie
  • *
  • Messages: 15
    • Voir le profil
Re : Comprend pas la directeion de X-Y
« Réponse #2 le: 09 juillet, 2017, 08:40:03 pm »
Bonjour,

Merci pour les infos.

Ok j'ai compris pour les axes et du principe de l'ardoise...

Mais est-ce que les moteur ne devrait pas tourner un en sens inverse de l'autre ?????

Pour ce qui est des EndStop, il y a  2  possibilités de les connecter.

Voir photo, je suis exactement connecter de cette manière, sauf avec seulement un extrudeur en MK8, et un moteur en Z seulement.

J'utilise le firmeware Marlin pris tel quel dans Github

merci encore

cameleon


















« Modifié: 09 juillet, 2017, 08:42:32 pm par cameleon »

cameleon

  • Newbie
  • *
  • Messages: 15
    • Voir le profil
Re : Comprend pas la directeion de X-Y
« Réponse #3 le: 09 juillet, 2017, 10:57:05 pm »
Bonjour

Tes suggestions ont été profitable.

Effectivement le nema du Y était défectueux. Malheureusement j'en ai pas d'autre.

J'ai des némas, mais les fils ne sont pas de la même couleur que ceux que j'ai normalement.

Normalement ils sont "noir-rouge-vert et bleu"

Mes autres némas les couleurs sont "rouge-vert-jaune et bleu"

Je vais faire des tests demain pour savoir qui est qui ????

Je donne des nouvelles.

merci encore

cameleon