Auteur Sujet: [Résolu] Arrêt de la SmartCore en cours d'impression  (Lu 2166 fois)

BrunoBellamy

  • Hero Member
  • *****
  • Messages: 2095
    • Voir le profil
    • Bellaminettes Blog
[Résolu] Arrêt de la SmartCore en cours d'impression
« le: 11 février, 2015, 01:16:53 pm »
Hier, lors d'une impression un peu longue (encore que ça n'avait rien d'affolant, je crois que ça a "flanché" au bout d'1H30…), la SmartCore s'est interrompue alors que l'impression n'en était encore qu'à la moitié.

Arrêt des moteurs, et lumière rouge clignotante sur la RAMPS…

Ce matin, tout remarchait, j'ai juste perdu un peu de temps et de filament. ;)

J'imagine qu'il peut y avoir plusieurs causes, mais je voudrais savoir si d'autres ont déjà été confronté au même souci (y compris bien sûr avec la SmartRap). J'utilise un Raspberry Pi avec OctoPi, donc ça rajoute des causes possibles d'interruption, mais par exemple je ne sais pas si une coupure réseau (je n'en ai pas remarqué à ce moment là, mais va savoir) peut interrompre l'impression quand on utilise ce système.

Est-ce qu'une surchauffe de la RAMPS peut occasionner ce comportement ? Y'a-t-il déjà eu ce genre de souci et ce diagnostic là ? Si c'est ça, je peux installer un ventilo. Je viens de recevoir un 50mm, et je ne devrais pas avoir trop de mal à lui fabriquer un support et à le brancher quelque part sur la RAMPS, mais ça m'intéresserait de savoir si c'est bien ça la cause de l'interruption (et donc si j'applique la bonne solution).

Aze

  • Sr. Member
  • ****
  • Messages: 462
    • Voir le profil
Re: Arrêt de la SmartCore en cours d'impression
« Réponse #1 le: 11 février, 2015, 01:37:55 pm »
Faudrait que tu précises un peu ton cas:
tu imprimais via une carte SD ou via un ordi?
Si c'est l'ordi, y a pas une mise en veille ou un bête truc du genre responsable?
Est-ce que tu as mis le câble USB bleu fourni avec la Ramps ou un autre plus long? (moi j'ai eu ce soucis, le câble USB sur la Ramps est un point sensible, il ne tolère pas grand chose).

BrunoBellamy

  • Hero Member
  • *****
  • Messages: 2095
    • Voir le profil
    • Bellaminettes Blog
Re: Arrêt de la SmartCore en cours d'impression
« Réponse #2 le: 11 février, 2015, 01:54:38 pm »
C'est le Raspberry Pi sous Octopi qui gérait directement l'imprimante, donc pas d'ordi "classique" (OctoPi est vraiment fait pour, donc non il ne se met pas en veille en cours d'impression, ça serait vraiment nouille… ;)), ni de SD.

Je n'ai pas le câble USB bleu (certes très joli, par ailleurs :)), Serge a oublié de le mettre avec la SmartCore, donc j'ai mis un bête câble USB que j'avais en rab, entre le RPI et l'Arduino de la SmartCore.

Ça pourrait être ça ? Pourtant, j'ai imprimé pas mal de trucs avant cet "incident", donc ça m'étonne quand même un peu…

spyd

  • Global Moderator
  • *****
  • Messages: 1888
    • Voir le profil
  • 3d printer: smartrapcore alu
  • buying date: décembre 2015
  • country/Pays: France
  • region/departement: haute-savoie 74
Re: Arrêt de la SmartCore en cours d'impression
« Réponse #3 le: 11 février, 2015, 01:57:52 pm »
Il roule en serveur octopy donc ca peu etre l'Usb. Ca peux aussi être une sur chauffe des drivers.
Branchement du ventilo de tête sur le bornier d'alim = HOTEND bien ventillée!!!!!

My thingiverse : http://www.thingiverse.com/spyd6/designs
powerfull tools, free and privacy friendly : https://framasoft.org/[/url

BrunoBellamy

  • Hero Member
  • *****
  • Messages: 2095
    • Voir le profil
    • Bellaminettes Blog
Re: Arrêt de la SmartCore en cours d'impression
« Réponse #4 le: 11 février, 2015, 02:07:09 pm »
Bon, je vais appliquer les deux solutions, ça me semble assez indiqué. ;)

Serge, est-ce qu'éventuellement il serait possible que tu m'envoies ce fameux câble USB, s'il est plus sûr ? C'est vrai que que ce j'ai ici c'est du bête câble générique, je ne sais pas si c'est spécialement blindé ou si c'est assez costaud…

Je vais aussi m'imprimer un support pour fixer mon ventilo tout neuf juste au-dessus de la RAMPS et refroidir tout ça…

BrunoBellamy

  • Hero Member
  • *****
  • Messages: 2095
    • Voir le profil
    • Bellaminettes Blog
Re: Arrêt de la SmartCore en cours d'impression
« Réponse #5 le: 12 février, 2015, 12:54:57 pm »
Bon, je me suis imprimé un petit support pour un ventilo 50mm :



Je le mets en marche au début de l'impression avec un M106, et je l'arrête à la fin avec un M107 (je l'ai branché en D9). Ça rajoute un petit peu de bruit, mais si ça m'évite de perdre 10m de filament à chaque fois que l'impression dure un peu longtemps, c'est pas plus mal. ;)

Reste à vérifier que ça résout bel et bien mon souci d'interruption inopinée de l'impression. J'ai relancé l'impression du corps de mon extrudeur, qui est assez compliqué et donc long à sortir, et on verra bien…

BrunoBellamy

  • Hero Member
  • *****
  • Messages: 2095
    • Voir le profil
    • Bellaminettes Blog
Re: [Résolu] Arrêt de la SmartCore en cours d'impression
« Réponse #6 le: 15 février, 2015, 12:49:26 pm »
So far so good : mes impressions "longues" (plus d'une heure) se sont déroulées sans souci depuis que j'ai installé ce ventilateur au-dessus de la RAMPS. :)

Sans pouvoir encore être affirmatif à 100%, j'ai toutes les raisons de supposer que le problème venait bien d'une surchauffe, et que ce ventilo est donc la solution, que je me permets donc de recommander. :)

Inutile de dire qu'il est impératif de le mettre en route automatiquement en début d'impression, donc faut bien penser à ajouter un M106 dans le start code (et un M107 dans le end code).

Fred_replicant

  • Hero Member
  • *****
  • Messages: 833
    • Voir le profil
Re: [Résolu] Arrêt de la SmartCore en cours d'impression
« Réponse #7 le: 15 février, 2015, 01:42:55 pm »
Bizarre, ma ramps ne chauffe jamais. C'est plutôt les moteurs. Les radiateurs des pololu ne sont jamais chauds.
Smartrap Orange V 0.4.9.2 Jheadlite 0.35 GT2
(mais bon, je vais la démonter ....snif)

CORE 50X50 Fred_Design

babas

  • Full Member
  • ***
  • Messages: 104
    • Voir le profil
Re: [Résolu] Arrêt de la SmartCore en cours d'impression
« Réponse #8 le: 15 février, 2015, 01:57:47 pm »
sur quels pin de la ramps as-tu relié le ventilateur ?

BrunoBellamy

  • Hero Member
  • *****
  • Messages: 2095
    • Voir le profil
    • Bellaminettes Blog
Re: [Résolu] Arrêt de la SmartCore en cours d'impression
« Réponse #9 le: 15 février, 2015, 02:36:09 pm »
Comme j'ai dit, je ne suis pas sûr à 100%. Je suis juste sûr que mes certaines de mes impressions longues se sont interrompues brusquement. Ça n'est plus arrivé depuis que j'ai installé ce ventilo, donc je peux juste dire que ça va mieux "depuis" sans pouvoir affirmer que ça va mieux "grâce à ça".
Si ça se reproduit, je saurai que ça n'était pas la solution. J'ai pas fait beaucoup d'impressions depuis, à vrai dire, donc wait & see.

J'ai branché ce ventilo en D9, c'est ce qui fait que je peux le commander avec un M106/M107.

babas

  • Full Member
  • ***
  • Messages: 104
    • Voir le profil
Re: [Résolu] Arrêt de la SmartCore en cours d'impression
« Réponse #10 le: 15 février, 2015, 03:03:14 pm »
ha mince, sur mon MOD, y aura un plateau chauffant pour impression d'ABS (oui, je sait, je m'éloigne un peu du concept Bio de Serge). du coup, je vais sûrement passer par un branchement direct sur l'alim, vu que je peut commander le démarrage de celle-ci par M80 / M81.

Merci pour ces précisions, même si au final, les interruptions ne sont pas dû à l'absence de refroidissement...ça peut pas faire de mâl :) !

BrunoBellamy

  • Hero Member
  • *****
  • Messages: 2095
    • Voir le profil
    • Bellaminettes Blog
Re: [Résolu] Arrêt de la SmartCore en cours d'impression
« Réponse #11 le: 15 février, 2015, 03:04:22 pm »
J'espère quand même que je vais finir par piger ce qui a posé problème… :(

BrunoBellamy

  • Hero Member
  • *****
  • Messages: 2095
    • Voir le profil
    • Bellaminettes Blog
Re: Arrêt de la SmartCore en cours d'impression
« Réponse #12 le: 22 février, 2015, 11:00:01 am »
Bon, le problème se reproduit (arrêt intempestif de l'impression) de plus en plus souvent… Certaines impressions ne dépassent même pas quelques secondes avant de s'arrêter. :(

De toute évidence, ça n'est donc pas une surchauffe de la RAMPS, et ma petite installation avec ventilo ne résout donc rien, et ne fait que faire un peu plus de bruit (je crois que je vais m'en passer à l'avenir ;)).

J'ai cependant circonscrit le problème :
- j'ai écrit un gcode bidon (homing X Y et Z, bed levelling, suite de mouvements bidon en X et Y, puis homing et arrêt des moteurs. Pas de montée en température ni d'extrusion).
- je l'ai exécuté en mode "normal", c'est à dire pour moi en l'envoyant au Raspberry Pi installé dans la SmartRapCore et tournant sous Octopi : ça finit toujours par s'arrêter (jamais au même moment, donc ça n'est pas spécifique au code), et ça déconnecte OctoPi. Je ne peux reprendre la main qu'en éteignant/rallumant la machine.
- je l'ai exécuté (exactement le même code) à partir d'une SD card insérée dans mon petit LCD Full Graphic (heureusement que j'ai ce bidule !), et ça se passe très bien, jamais d'interruption. À noter que pendant tout le temps de l'exécution du code, OctoPi reste allumé, et fonctionne très bien (il ne fait que m'envoyer la température de la pièce et, surtout, l'image en temps réel de la petite webcam solidaire du plateau d'impression), et ça ne lui pose aucun souci.

La conclusion à laquelle je parviens pour l'instant, c'est que j'ai un sérieux souci de communication entre le Raspberry Pi et l'Arduino de la SmartRapCore, et qu'il est suffisant pour planter le Raspberry Pi.

Je ne pense pas, en effet, que ça ait planté seulement OctoPi, puisque après une interruption d'impression, je ne peux plus me connecter du tout au Raspberry Pi (ancien modèle B) via ssh.

Il faut déjà, je pense, que j'explore la piste du câble USB (le câble d'origine manquait dans le paquet de l'imprimante). Je vais suivre à nouveau le même protocole avec tout ce que j'ai ici comme câble USB de rechange, je verrai bien.

Si quelqu'un a une autre idée/suggestion…

Fred_replicant

  • Hero Member
  • *****
  • Messages: 833
    • Voir le profil
Re: Arrêt de la SmartCore en cours d'impression
« Réponse #13 le: 22 février, 2015, 11:09:44 am »
Salut Bruno. Je pense à un problème d alimentation de l USB. Peux tu essayer avec un USB auto alimenté ?

Smartrap Orange V 0.4.9.2 Jheadlite 0.35 GT2
(mais bon, je vais la démonter ....snif)

CORE 50X50 Fred_Design

BrunoBellamy

  • Hero Member
  • *****
  • Messages: 2095
    • Voir le profil
    • Bellaminettes Blog
Re: Arrêt de la SmartCore en cours d'impression
« Réponse #14 le: 22 février, 2015, 11:17:51 am »
Je soupçonne aussi un truc comme ça…
Pour alimenter le RPI j'utilise un chargeur Velleman 2 ampères (http://www.amazon.fr/gp/product/B0098IH91I?psc=1), en principe c'est vraiment du bon matos. En revanche, le câble qui va de cette alim au RPI est peut-être un peu cheap. Je crois que j'en ai un autre en stock quelque part, je vais changer ça pour voir.

Là j'ai retesté avec un autre câble USB et le code est allé jusqu'au bout, mais le RPI a planté juste à la fin, après l'arrêt des moteurs de l'imprimante, donc c'est pas 100% probant… ;)